Author Topic: Planets misplaced  (Read 439 times)

pclaurent

  • Newbie
  • *
  • Posts: 23
    • View Profile
Planets misplaced
« on: January 06, 2018, 03:25:06 PM »
[v. 1.0.8 Android]

Planets do not seem to be at the right place. For example, let's create a custom mission for 2017/01/01. Heliocentric longitude of Mars is 16.2, and earth is 100.8 (source: JPL). In the orbit planner at this date, earth and mars are around 170 apart (should be 84). Same thing if you try 2018/01/01. Mars should be at 194.1, and Earth at 100.5. That is not what we see in the orbit planner...

So with the current version, the - real - launch windows cannot be used in the simulator for a trip to Mars. Should be fixed in next release if we want to simulate travels to other planets...

For information, here are some launch windows for traveling from earth to mars. At these periods, we should be able to do a Hohmann transfer to mars (dates are approximations, and launch windows are generally 1 week or 10-days large):

2018/5/1
2020/6/19
2022/8/8
2024/9/26
...
2099/6/23
« Last Edit: January 07, 2018, 09:33:36 AM by pclaurent »

jcarrion

  • Administrator
  • Sr. Member
  • *****
  • Posts: 441
    • View Profile
Re: Planets misplaced
« Reply #1 on: January 11, 2018, 02:34:16 PM »
Thanks !.
I ll have a look at it . :)

jcarrion

  • Administrator
  • Sr. Member
  • *****
  • Posts: 441
    • View Profile
Re: Planets misplaced
« Reply #2 on: January 11, 2018, 06:17:12 PM »
hi PcLaurent.

Mars should be now in the correct position.  I guess that would be in the next weekly  automated-beta build . 

Thanks.,