Author Topic: Game Translator needed? Xperia Z1 Compatible?  (Read 1867 times)

Crazyboy123232

  • Newbie
  • *
  • Posts: 1
    • View Profile
Game Translator needed? Xperia Z1 Compatible?
« on: December 15, 2014, 04:02:46 PM »
Hey guys, I'm new in here. I discovered this upcoming Simulator while I was searching for some Orbiter 2010 Addons. I really think this one got Potential and I am asking myself two questions :
Is a Game Translator needed?  I'm a German student and I'd like to translate the final product or the beta versions and so on. Qualifications: Mark A in final English Exam (Writing)  and the same in speaking tests. Cambridge English speaker Certificate. I really would like to do that and if any developer reads this, just write me a PM :)
Other qquestion: Is the game coming out to ALL actual Android Devices?  Like the Sony Xperia Z series? 
Greetings Crazyboy ;)